# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*_(\d{2})(\d{2})(\d{4})-(\d{2})(\d{2})(\d{2})/$1\/$2\/ $4:$5:$6/g;t' <<< "1234567_29052017-122959.jpg"