$re = '/.*_(\d{2})(\d{2})(\d{4})-(\d{2})(\d{2})(\d{2})/';
$str = '1234567_29052017-122959.jpg';
$subst = "$1/$2/ $4:$5:$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;