#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*_(\d{2})(\d{2})(\d{4})-(\d{2})(\d{2})(\d{2})"
Local $sString = "1234567_29052017-122959.jpg"
Local $sSubst = "$1/$2/ $4:$5:$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)