using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*_(\d{2})(\d{2})(\d{4})-(\d{2})(\d{2})(\d{2})";
string substitution = @"$1/$2/ $4:$5:$6";
string input = @"1234567_29052017-122959.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}