const regex = /.*_(\d{2})(\d{2})(\d{4})-(\d{2})(\d{2})(\d{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*_(\\d{2})(\\d{2})(\\d{4})-(\\d{2})(\\d{2})(\\d{2})', 'g')
const str = `1234567_29052017-122959.jpg`;
const subst = `$1/$2/ $4:$5:$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);