# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*_(\d{2})(\d{2})(\d{4})-(\d{2})(\d{2})(\d{2})"
test_str = "1234567_29052017-122959.jpg"
subst = "$1/$2/ $4:$5:$6"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.