use strict;
my $str = '1234567_29052017-122959.jpg';
my $regex = qr/.*_(\d{2})(\d{2})(\d{4})-(\d{2})(\d{2})(\d{2})/p;
my $subst = '$1/$2/ $4:$5:$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";