import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*_(\\d{2})(\\d{2})(\\d{4})-(\\d{2})(\\d{2})(\\d{2})";
final String string = "1234567_29052017-122959.jpg";
final String subst = "$1/$2/ $4:$5:$6";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}