# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:.(?=.*\n(\2?.)))*?X.*\n)\2?./$1$2Y/gm;t' <<< "X.........
..........
...X......
..........
..X.......
..........
.......X..
..........
.........X
.........."