import Foundation
let pattern = #"^((?:.(?=.*\n(\2?.)))*?X.*\n)\2?."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
X.........
..........
...X......
..........
..X.......
..........
.......X..
..........
.........X
..........
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2Y"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)