re = /^((?:.(?=.*\n(\2?.)))*?X.*\n)\2?./m
str = 'X.........
..........
...X......
..........
..X.......
..........
.......X..
..........
.........X
..........'
subst = '$1$2Y'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result