use strict;
my $str = 'X.........
..........
...X......
..........
..X.......
..........
.......X..
..........
.........X
..........';
my $regex = qr/^((?:.(?=.*\n(\2?.)))*?X.*\n)\2?./mp;
my $subst = '$1$2Y';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";