import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:.(?=.*\\n(\\2?.)))*?X.*\\n)\\2?.";
final String string = "X.........\n"
+ "..........\n\n"
+ "...X......\n"
+ "..........\n\n"
+ "..X.......\n"
+ "..........\n\n"
+ ".......X..\n"
+ "..........\n\n"
+ ".........X\n"
+ "..........";
final String subst = "$1$2Y";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}