using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:.(?=.*\n(\2?.)))*?X.*\n)\2?.";
string substitution = @"$1$2Y";
string input = @"X.........
..........
...X......
..........
..X.......
..........
.......X..
..........
.........X
..........";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}