$re = '/^((?:.(?=.*\n(\2?.)))*?X.*\n)\2?./m';
$str = 'X.........
..........
...X......
..........
..X.......
..........
.......X..
..........
.........X
..........';
$subst = "$1$2Y";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;