#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?:.(?=.*\n(\2?.)))*?X.*\n)\2?."
Local $sString = "X........." & @CRLF & _
".........." & @CRLF & _
"" & @CRLF & _
"...X......" & @CRLF & _
".........." & @CRLF & _
"" & @CRLF & _
"..X......." & @CRLF & _
".........." & @CRLF & _
"" & @CRLF & _
".......X.." & @CRLF & _
".........." & @CRLF & _
"" & @CRLF & _
".........X" & @CRLF & _
".........."
Local $sSubst = "$1$2Y"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)