# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\u0591-\u05C7]//g;t' <<< "וַֽיַּעֲבֹר֙ אֶת־מִצְפֵּ֣ה גִלְעָ֔ד"