$re = '/[\u0591-\u05C7]/';
$str = 'וַֽיַּעֲבֹר֙ אֶת־מִצְפֵּ֣ה גִלְעָ֔ד';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;