import re
regex = re.compile(r"[\u0591-\u05C7]")
test_str = "וַֽיַּעֲבֹר֙ אֶת־מִצְפֵּ֣ה גִלְעָ֔ד"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)