const regex = /[\u0591-\u05C7]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\u0591-\\u05C7]', 'g')
const str = `וַֽיַּעֲבֹר֙ אֶת־מִצְפֵּ֣ה גִלְעָ֔ד`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);