#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]*(?=;0;0;6275)"
Local $sString = "m[mi++]="28.01.17 18:20:00|623;0;8368|0;0;0;6275;0;0"" & @CRLF & _
"m[mi++]="28.01.17 18:15:00|623;0;8317|0;0;0;6275;0;0"" & @CRLF & _
"m[mi++]="28.01.17 18:10:00|652;0;8265|0;0;0;6275;0;0""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")