# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[0-9]*(?=;0;0;6275)"
test_str = ("m[mi++]=\"28.01.17 18:20:00|623;0;8368|0;0;0;6275;0;0\"\n"
"m[mi++]=\"28.01.17 18:15:00|623;0;8317|0;0;0;6275;0;0\"\n"
"m[mi++]=\"28.01.17 18:10:00|652;0;8265|0;0;0;6275;0;0\"")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.