use strict;
my $str = 'm[mi++]="28.01.17 18:20:00|623;0;8368|0;0;0;6275;0;0"
m[mi++]="28.01.17 18:15:00|623;0;8317|0;0;0;6275;0;0"
m[mi++]="28.01.17 18:10:00|652;0;8265|0;0;0;6275;0;0"';
my $regex = qr/[0-9]*(?=;0;0;6275)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}