import Foundation
let pattern = #"[0-9]*(?=;0;0;6275)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
m[mi++]="28.01.17 18:20:00|623;0;8368|0;0;0;6275;0;0"
m[mi++]="28.01.17 18:15:00|623;0;8317|0;0;0;6275;0;0"
m[mi++]="28.01.17 18:10:00|652;0;8265|0;0;0;6275;0;0"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}