const regex = /[0-9]*(?=;0;0;6275)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]*(?=;0;0;6275)', '')
const str = `m[mi++]="28.01.17 18:20:00|623;0;8368|0;0;0;6275;0;0"
m[mi++]="28.01.17 18:15:00|623;0;8317|0;0;0;6275;0;0"
m[mi++]="28.01.17 18:10:00|652;0;8265|0;0;0;6275;0;0"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}