using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]*(?=;0;0;6275)";
string input = @"m[mi++]=""28.01.17 18:20:00|623;0;8368|0;0;0;6275;0;0""
m[mi++]=""28.01.17 18:15:00|623;0;8317|0;0;0;6275;0;0""
m[mi++]=""28.01.17 18:10:00|652;0;8265|0;0;0;6275;0;0""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}