import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]*(?=;0;0;6275)";
final String string = "m[mi++]=\"28.01.17 18:20:00|623;0;8368|0;0;0;6275;0;0\"\n"
+ "m[mi++]=\"28.01.17 18:15:00|623;0;8317|0;0;0;6275;0;0\"\n"
+ "m[mi++]=\"28.01.17 18:10:00|652;0;8265|0;0;0;6275;0;0\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}