re = /[0-9]*(?=;0;0;6275)/
str = 'm[mi++]="28.01.17 18:20:00|623;0;8368|0;0;0;6275;0;0"
m[mi++]="28.01.17 18:15:00|623;0;8317|0;0;0;6275;0;0"
m[mi++]="28.01.17 18:10:00|652;0;8265|0;0;0;6275;0;0"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end