#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\+\d{1,3})?\(\d{2,3}\))?\d{4,5}-\d{4}$"
Local $sString = "00000-000" & @CRLF & _
"0000-000" & @CRLF & _
"00000-0000" & @CRLF & _
"07625-034" & @CRLF & _
"88756-9039" & @CRLF & _
"(11)55554-5555" & @CRLF & _
"+55(11)5555-5555" & @CRLF & _
"33085-098" & @CRLF & _
"+000(00)0000-0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")