package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\+\d{1,3})?\(\d{2,3}\))?\d{4,5}-\d{4}$`)
var str = `00000-000
0000-000
00000-0000
07625-034
88756-9039
(11)55554-5555
+55(11)5555-5555
33085-098
+000(00)0000-0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}