use strict;
my $str = '00000-000
0000-000
00000-0000
07625-034
88756-9039
(11)55554-5555
+55(11)5555-5555
33085-098
+000(00)0000-0000';
my $regex = qr/^((\+\d{1,3})?\(\d{2,3}\))?\d{4,5}-\d{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}