import re
regex = re.compile(r"^((\+\d{1,3})?\(\d{2,3}\))?\d{4,5}-\d{4}$", flags=re.MULTILINE)
test_str = ("00000-000\n"
"0000-000\n"
"00000-0000\n"
"07625-034\n"
"88756-9039\n"
"(11)55554-5555\n"
"+55(11)5555-5555\n"
"33085-098\n"
"+000(00)0000-0000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")