using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\+\d{1,3})?\(\d{2,3}\))?\d{4,5}-\d{4}$";
string input = @"00000-000
0000-000
00000-0000
07625-034
88756-9039
(11)55554-5555
+55(11)5555-5555
33085-098
+000(00)0000-0000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}