// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\+\d{1,3})?\(\d{2,3}\))?\d{4,5}-\d{4}$").unwrap();
let string = "00000-000
0000-000
00000-0000
07625-034
88756-9039
(11)55554-5555
+55(11)5555-5555
33085-098
+000(00)0000-0000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}