import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\+\\d{1,3})?\\(\\d{2,3}\\))?\\d{4,5}-\\d{4}$";
final String string = "00000-000\n"
+ "0000-000\n"
+ "00000-0000\n"
+ "07625-034\n"
+ "88756-9039\n"
+ "(11)55554-5555\n"
+ "+55(11)5555-5555\n"
+ "33085-098\n"
+ "+000(00)0000-0000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}