# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([0-9]+)\/([0-9]+)\/([0-9a-zA-Z_-]+)\/([0-9]+)\/(thumbnail+)\/([0-9a-zA-Z\-\_]+)(\.jpg)$/\/upload\/$2\/$3\/$4\/$1_sm.jpg/gm;t' <<< "1530778610/2018/Jul/05/thumbnail/lake-u_8610.jpg
1530778610/2018/Jul/05/thumbnail/lakeu_8610.jpg"