const regex = new RegExp('^([0-9]+)/([0-9]+)/([0-9a-zA-Z_-]+)/([0-9]+)/(thumbnail+)/([0-9a-zA-Z\\-\\_]+)(\\.jpg)$', 'gm')
const str = `1530778610/2018/Jul/05/thumbnail/lake-u_8610.jpg
1530778610/2018/Jul/05/thumbnail/lakeu_8610.jpg`;
const subst = `/upload/$2/$3/$4/$1_sm.jpg`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);