using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9]+)/([0-9]+)/([0-9a-zA-Z_-]+)/([0-9]+)/(thumbnail+)/([0-9a-zA-Z\-\_]+)(\.jpg)$";
string substitution = @"/upload/$2/$3/$4/$1_sm.jpg";
string input = @"1530778610/2018/Jul/05/thumbnail/lake-u_8610.jpg
1530778610/2018/Jul/05/thumbnail/lakeu_8610.jpg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}