use strict;
my $str = '1530778610/2018/Jul/05/thumbnail/lake-u_8610.jpg
1530778610/2018/Jul/05/thumbnail/lakeu_8610.jpg';
my $regex = qr~^([0-9]+)/([0-9]+)/([0-9a-zA-Z_-]+)/([0-9]+)/(thumbnail+)/([0-9a-zA-Z\-\_]+)(\.jpg)$~mp;
my $subst = '/upload/$2/$3/$4/$1_sm.jpg';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";