$re = '~^([0-9]+)/([0-9]+)/([0-9a-zA-Z_-]+)/([0-9]+)/(thumbnail+)/([0-9a-zA-Z\-\_]+)(\.jpg)$~m';
$str = '1530778610/2018/Jul/05/thumbnail/lake-u_8610.jpg
1530778610/2018/Jul/05/thumbnail/lakeu_8610.jpg';
$subst = "/upload/$2/$3/$4/$1_sm.jpg";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;