import Foundation
let pattern = #"^([0-9]+)/([0-9]+)/([0-9a-zA-Z_-]+)/([0-9]+)/(thumbnail+)/([0-9a-zA-Z\-\_]+)(\.jpg)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1530778610/2018/Jul/05/thumbnail/lake-u_8610.jpg
1530778610/2018/Jul/05/thumbnail/lakeu_8610.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/upload/$2/$3/$4/$1_sm.jpg"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)