#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\b(\w+@.*.com)\b.*)\2\b"
Local $sString = "999,222,999" & @CRLF & _
"mail,mail,nail," & @CRLF & _
"mail@sca.com,mail@sca.com" & @CRLF & _
"" & @CRLF & _
"site.com: mail@site.com,nail@site.com,mail@site.com" & @CRLF & _
"nite.com: info@nite.com,nail@site.com,nail@site.com"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)