const regex = /(\b(\w+@.*.com)\b.*)\2\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(\\w+@.*.com)\\b.*)\\2\\b', 'gm')
const str = `999,222,999
mail,mail,nail,
mail@sca.com,mail@sca.com
site.com: mail@site.com,nail@site.com,mail@site.com
nite.com: info@nite.com,nail@site.com,nail@site.com`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);