use strict;
my $str = '999,222,999
mail,mail,nail,
mail@sca.com,mail@sca.com
site.com: mail@site.com,nail@site.com,mail@site.com
nite.com: info@nite.com,nail@site.com,nail@site.com';
my $regex = qr/(\b(\w+@.*.com)\b.*)\2\b/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";