using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b(\w+@.*.com)\b.*)\2\b";
string substitution = @"\1";
string input = @"999,222,999
mail,mail,nail,
mail@sca.com,mail@sca.com
site.com: mail@site.com,nail@site.com,mail@site.com
nite.com: info@nite.com,nail@site.com,nail@site.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}