# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b(\w+@.*.com)\b.*)\2\b"
test_str = ("999,222,999\n"
"mail,mail,nail,\n"
"mail@sca.com,mail@sca.com\n\n"
"site.com: mail@site.com,nail@site.com,mail@site.com\n"
"nite.com: info@nite.com,nail@site.com,nail@site.com")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.