import Foundation
let pattern = #"(\b(\w+@.*.com)\b.*)\2\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
999,222,999
mail,mail,nail,
mail@sca.com,mail@sca.com
site.com: mail@site.com,nail@site.com,mail@site.com
nite.com: info@nite.com,nail@site.com,nail@site.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)