$re = '/(\b(\w+@.*.com)\b.*)\2\b/m';
$str = '999,222,999
mail,mail,nail,
mail@sca.com,mail@sca.com
site.com: mail@site.com,nail@site.com,mail@site.com
nite.com: info@nite.com,nail@site.com,nail@site.com';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;