import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(\\w+@.*.com)\\b.*)\\2\\b";
final String string = "999,222,999\n"
+ "mail,mail,nail,\n"
+ "mail@sca.com,mail@sca.com\n\n"
+ "site.com: mail@site.com,nail@site.com,mail@site.com\n"
+ "nite.com: info@nite.com,nail@site.com,nail@site.com";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}