#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s).*?(?:(?=([DKE])((?!\1)[DKE])([DKE])([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?))(\9\8\7\6\5\4\3\2\1|\7\6\5\4\3\2\1|\5\4\3\2\1|\3\2\1))"
Local $sString = "KEKEKEKD" & @CRLF & _
"abaabadfkfdDKEKDDEDDD" & @CRLF & _
"KEK" & @CRLF & _
"DKEKD" & @CRLF & _
"DED" & @CRLF & _
"DKEKDKEKD" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$10\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)